2009-09-20

Windows7/SB600환경에서 AHCI/RAID 사용하기

kkoyee.com에 'Windows 7 SB600 Driver'로 검색해 들어오시는 분이 많은 것 같아서 글을 남깁니다. 앞으로 AMD에서 Win7용 드라이버를 만들지, 만들지 않을지는 모르겠지만 어쩔 수 없이 비스타 드라이버를 사용해야 합니다.

SB600이 구형 하드웨어인 것은 사실이지만, 아직 모바일 M690T 칩셋도 있고, AMD가 SB7XX 사우스브리지를 약간의 시간차를 두고 출시하는 바람에 AMD7XX 노스브리지를 사용하는 보드중 간혹 SB600을 사용한 모델이 있습니다. 상당히 최근까지 SB600을 사용한 것으로 알고 있는데, 왜 Windows 7에 SB600드라이버가 기본 내장되지 않았는지 솔직히 이해하지 못하겠습니다.(심지어 제가 사용하는 메인보드는 바이오스 업데이트를 통해서 일부 AM3 CPU까지 사용이 가능합니다.)

우선 첫번째로 카탈리스트 9.8(9.9도 동일 드라이버, 참조 : http://support.amd.com/us/gpudownload/windows/Pages/integrated_vista64.aspx?type=2.7&product=&lang=English&rev=9.9&ostype= )에 포함되어 있는 1540.86버전 드라이버를 사용할 수 있는데, 상당수의 보드에서는 이 드라이버가 제대로 잡히지 않습니다. 제 환경에서는 윈도 설치 이후에는 강제로 잡아줄 수 있는데, 윈도 설치 과정에서는 제대로 잡히지 않았습니다. 차선책으로 선택 가능한 것이 카탈리스트 9.3(참조 : http://support.amd.com/us/gpudownload/windows/9-3/Pages/integrated_vista64.aspx?&lang=English)에 포함된 1540.47드라이버 인데, 64비트 환경에서는 비서명 드라이버라고 문제되는 경우가 있습니다.(64비트 환경에서 비서명 드라이버를 사용하기 위해서는 테스트 모드에 들어가야 합니다. 게다가 비서명 드라이버는 윈도 설치중 드라이버 로드가 힘듭니다.)

MSI와 Gigabyte의 AMD 7XX 칩셋 보드중 사우스브리지로 SB600을 사용한 모델을 찾아보니 몇개를 찾을 수 있었습니다. 동봉된 비스타용 드라이버를 사용하니 Windows7에서도 별 문제없이 사용할 수 있었습니다.(1540.47버전) 아마도 AMD에서 제공하는 1540.47버전 드라이버의 cat파일에 문제가 있는 모양입니다.


제가 사용한 것은 Gigabyte의 드라이버였고, 설치과정에서 드라이버를 로딩한 후 문제없이 설치 가능했습니다.
Windows 7 64비트용 드라이버가 아닌 비스타용 드라이버이기 때문에 어떤 문제가 발생할지 모른다는 위험이 있습니다.

출처 : http://www.gigabyte.com.tw/Support/Motherboard/Driver_Model.aspx?ProductID=2694&ost=others#anchor_os

비스타용 드라이버를 Windows7 환경에서 사용하는 것이기 때문에 꼭 백업한 후 사용하세요. 데이터 손실이나 하드웨어에 문제가 발생할 가능성이 있습니다.

혹시나 필터 드라이버가 필요하다면 카탈리스트 9.9에 포함된 드라이버를 잡아주면 문제없이 사용할 수 있습니다.

댓글 없음:

댓글 쓰기